CX-21 PIDs und (vielleicht) ein Problem mit dem Powermodul

Kay Hawaii
Drohnenkommandant
Wohnort:: Kiel, DE
Kopter & Zubehör: Mavic Pro --- Cheerson CX-20 --- Syma X5SW und ein ruhendes Eigenbauprojekt
Hat sich bedankt: 20 Mal
Danksagung erhalten: 21 Mal
Beiträge: 315
Registriert: 10:55 ,Fr 18. Nov 2016,

CX-21 PIDs und (vielleicht) ein Problem mit dem Powermodul

17:22 ,Sa 7. Okt 2017,

Hallo alle miteinander,

Zwischenzeitlich habe ich mir ja auch einen CX-21 zusammengezimmert.

Ich nutze den Q380 Frame, die empfohlenen Motoren nebst 1038er Props von Gemfan und ein APM mini 3.1
Als ESC nutze ich einen 4-fach QBrain 25A, den ich auf BLHeli umprogrammiert habe.
konzipiert ist das ganze als ein FPV Modell mit fest installierter Kamera (kein Gimbal o.ä.)

Soweit, so gut. Fliegen tut er auch, allerdings habe ich zwei Probleme

1. PID-Werte
Ich denke, die PID Werte stimmen nicht. Nach einem ersten Flug mit den Standardwerten habe ich die Parameter von Hans aufgespielt.
Damit flog er deutlich besser, kam aber trotzdem immer mal ins "Trudeln".

Dann habe ich andere Werte aufgespielt und zwar

RATE_PIT_D,0.0035
RATE_PIT_I,0.03
RATE_PIT_IMAX,1000
RATE_PIT_P,0.085
RATE_RLL_D,0.0035
RATE_RLL_I,0.03
RATE_RLL_IMAX,1000
RATE_RLL_P,0.085
RATE_YAW_D,0
RATE_YAW_I,0.02
RATE_YAW_IMAX,1000
RATE_YAW_P,0.15
RC_FEEL_RP,10

Damit flog er dann noch ein bisschen besser, wobei ich nicht weiß an welcher Stelle ich tunen soll... Wenn ich das Flugverhalten beschreiben soll, dann wie folgt:

Er hovert sauber in der Luft
Beim Geradeausflug sieht das eigentlich auch ganz sauber aus, aber wenn ich die Sticks loslasse, dann bleibt er nicht einfach stehen wie mein CX-20, sondern kommt so "wellenartig" nach 2-3 Wellenschlägen zum Stehen.
Dasselbe beobachte ich beim Seitwärtsflug.
Beim Sinkflug schaukelt er sich irgendwie auf, es sei denn ich mache das ganz langsam.

Wenn jemand eine Idee hätte, an welchem Wert ich hier drehen müsste, wäre ich dankbar!

2. Powermodul
Ich habe ein Powermodul verbaut und auch richtig verkabelt. Werte kommen an und werden mir über die Telemetrie angezeigt.

Ich habe das Modul auch kalibriert, stelle allerdings fest, dass die Amperewerte sich offenbar ständig verstellen. Das erste mal ist mir das aufgefallen, dass die angezeigte Batteriekapazität dermaßen schnell absank, dass es nur eine Fehlmessung sein konnte. Kein Wunder, beim Abschluss an den PC wurden mir plötzlich Werte von 250 Ampere angezeigt.

Spricht das für ein defektes Powermodul oder hat der APM irgendwie Probleme?


VG
Kay
-------------------
nach Diktat verreist
Benutzeravatar
doelle4
Einsatzleiter ;-)
Kontaktdaten:
Wohnort:: A-3900 Kleinreichenbach
Kopter & Zubehör: Cheerson CX20, Mobius Gimbal, FPV, Karbon Beine. CX-21, Syma X5C ,Zerotech Dobby, Eachine Falcon 180 und andere
Hat sich bedankt: 156 Mal
Danksagung erhalten: 571 Mal
Beiträge: 7377
Registriert: 14:32 ,Sa 25. Jul 2015,

Re: CX-21 PIDs und (vielleicht) ein Problem mit dem Powermodul

18:37 ,Sa 7. Okt 2017,

Hier was zu Pid Werten: http://www.michael-heck.net/index.php/t ... /pidtuning
bzw hier: http://kopterforum.at/cheerson-cx-20-qu ... -t678.html

Wie stellst du das Powermodul ein? Ich verwende H4 Autoscheinwerfer Glühlampe die etwa 50 Watt hat am 3S Lipo und ca 4,5 Ampere zieht
Die schliese ich an und messe mit Multimeter die Spannung und dann die Ampere und gebe die Werte im MP zum Abgleich ein.
Spannungswert ist aber weit wichtiger daher diesen messen und ziemlich zeitnah im Mp eingeben bis der richtige Teilerfaktor ermittelt ist und der berechnete Wert ziemlich übereinstimmt.
Gruß Hans
Kay Hawaii
Drohnenkommandant
Wohnort:: Kiel, DE
Kopter & Zubehör: Mavic Pro --- Cheerson CX-20 --- Syma X5SW und ein ruhendes Eigenbauprojekt
Hat sich bedankt: 20 Mal
Danksagung erhalten: 21 Mal
Beiträge: 315
Registriert: 10:55 ,Fr 18. Nov 2016,

Re: CX-21 PIDs und (vielleicht) ein Problem mit dem Powermodul

19:05 ,Sa 7. Okt 2017,

Hi Hans,

ich messe mit laufenden Motoren und umgedrehten Props mit zwischen Akku und Kopter geschaltetem Messgerät. Im Bereich um 20A stelle ich die Werte dann im MP/APM Planner ein.

Beim CX-20 habe ich das einmal eingestellt. Seitdem läuft es.
Beim CX-21 bleiben die Werte irgendwie nicht erhalten und er zeigt mir irgendwelche Fantasiewerte an.

Der Spannungswert funktioniert soweit. Das Problem habe ich nur beim Strom.

VG
Kay
-------------------
nach Diktat verreist
Benutzeravatar
Wolfgang Blumen
Forumskönig
Kontaktdaten:
Wohnort:: Saarland
Kopter & Zubehör: CX-20 Cheerson mit Carsten's Ultraleicht-Landegestell u. Gimbal, RunCam1, PM, Telemetrie, OSD, FPV, Spektrum DX9 + DX18. T-Drones 380er Hexa. Mini Hexe180. EACHINE i6, Falcon180, C-Fly-Dream, 4 Mini FPV-Racer, diverse Flächenmodelle, Traxxas Summit. MPX EasyGlider4.
Hat sich bedankt: 383 Mal
Danksagung erhalten: 437 Mal
Beiträge: 4417
Registriert: 01:19 ,Mo 7. Dez 2015,

Re: CX-21 PIDs und (vielleicht) ein Problem mit dem Powermodul

22:00 ,Sa 7. Okt 2017,

Hallo Kay,

wenn Du noch ein PM hast tausch mal,
oder kontrollier die Lötstellen auf dem PM.

Da gab es mal verkehrte Widerstände:
PM-ALI-5V.jpg
PM-ALI-U-I.jpg
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
liebe Grüße Wolfgang
Benutzeravatar
mastersurferde
Forumskönig
Wohnort:: Bayern
Hat sich bedankt: 47 Mal
Danksagung erhalten: 262 Mal
Beiträge: 4238
Registriert: 15:41 ,Di 1. Sep 2015,

Re: CX-21 PIDs und (vielleicht) ein Problem mit dem Powermodul

22:50 ,Sa 7. Okt 2017,

Bei den Powermodulen sind viele Nieten im Umlauf - ich hab da auch ein paar davon.
Meistens klappt die Messung nicht, wenn der USB mit dem PC verbunden ist - deswegen stelle ich das immer über die Telemetrie ein.


Nimm mal Pitch_I und Roll_I von 0,03 auf 0,06 hoch - damit sollte es deutlich besser sein.

Gruß
Stefan
Kay Hawaii
Drohnenkommandant
Wohnort:: Kiel, DE
Kopter & Zubehör: Mavic Pro --- Cheerson CX-20 --- Syma X5SW und ein ruhendes Eigenbauprojekt
Hat sich bedankt: 20 Mal
Danksagung erhalten: 21 Mal
Beiträge: 315
Registriert: 10:55 ,Fr 18. Nov 2016,

Re: CX-21 PIDs und (vielleicht) ein Problem mit dem Powermodul

22:57 ,So 8. Okt 2017,

Ich habe mir jetzt mal ein neues Powermodul bestellt...

Danke für die Tips mit den PIDs ... ich werds mal mastersurferde's Tip mit den I-Werten probieren und mich langsam rantasten.

Blöd, dass ich derzeit keine Möglichkeit habe, die Werte auf dem Feld zu ändern und immer ein Stückchen fahren muss, bevor ich fliegen kann :-/

Guten Start in die Woche an alle!

VG
Kay
-------------------
nach Diktat verreist
Kay Hawaii
Drohnenkommandant
Wohnort:: Kiel, DE
Kopter & Zubehör: Mavic Pro --- Cheerson CX-20 --- Syma X5SW und ein ruhendes Eigenbauprojekt
Hat sich bedankt: 20 Mal
Danksagung erhalten: 21 Mal
Beiträge: 315
Registriert: 10:55 ,Fr 18. Nov 2016,

Re: CX-21 PIDs und (vielleicht) ein Problem mit dem Powermodul

09:17 ,Mi 18. Okt 2017,

Wow, nach gerade einmal 8 Tagen sind die Powermodule da.

Bild

Das rote ist dasselbe was ich schon eingebaut habe.

Das andere hat leider keine Beschriftung auf der Platine. Kann da jemand aushelfen?

VG
Kay


Gesendet von iPhone mit Tapatalk
-------------------
nach Diktat verreist
Kay Hawaii
Drohnenkommandant
Wohnort:: Kiel, DE
Kopter & Zubehör: Mavic Pro --- Cheerson CX-20 --- Syma X5SW und ein ruhendes Eigenbauprojekt
Hat sich bedankt: 20 Mal
Danksagung erhalten: 21 Mal
Beiträge: 315
Registriert: 10:55 ,Fr 18. Nov 2016,

CX-21 PIDs und (vielleicht) ein Problem mit dem Powermodul

10:50 ,So 22. Okt 2017,

So,

Ich habe zwischenzeitlich das baugleiche Powermodul eingebaut und hatte danach dieselben Probleme.

Da der Empfänger praktisch direkt neben dem PM installiert ist, habe ich diesen danach in einiger Entfernung angebracht um eventuelle Störsignale auszuschließen. Das hat aber auch nichts gebracht.

Als weitere Fehlerquelle habe ich das Mavlink2Hott Modul neu programmiert (ich fliege mit Graupner). Auch keine Besserung.

Im nächsten Schritt konnte ich das Problem aber nun wohl finden.

Und zwar habe ich nochmal eine Kalibration durchgeführt.

Beim Discomnect habe ich dabei zufällig noch auf die Werte geschaut und gesehen, dass die Ampere per Volt genau beim Klick auf Disconnect von 9.227 auf ca. 164.000 gesprungen sind.

Klar, dass es dann zu solchen Werten kommt.

Habe danach nochmal verbunden und diesen Wert per Hand eingegeben. Diesmal scheint er den auch behalten zu haben.

Mal sehen! Ein erster Test war vielversprechend.

Wenn es das war, dann muss ich nur noch die PIDs in den Griff bekommen. Mastersurferdes Anregung habe ich schon eingetragen.

VG
Kay




Gesendet von iPhone mit Tapatalk
-------------------
nach Diktat verreist
  • Vergleichbare Themen
    Antworten
    Zugriffe
    Letzter Beitrag

Zurück zu „CX-21 & andere Musterkopter Sets“


drohne
drohne

Insgesamt sind 70 Besucher online :: 3 sichtbare Mitglieder, 0 unsichtbare Mitglieder und 67 Gäste
Mitglieder: Bing [Bot], Google [Bot], jako
Der Besucherrekord liegt bei 106 Besuchern, die am 18:15 ,Sa 15. Dez 2018, gleichzeitig online waren.
Beiträge insgesamt 69338
Themen insgesamt 4768
Mitglieder insgesamt 2899
Unser neuestes Mitglied: Elmar7311
Heute hat kein Mitglied Geburtstag
FPV Antennen