Quick search
Forums: Topics: Users:
    Dealextreme RC Master Amazon.de Banggood Ebay.de Gearbest Aliexpress

CX-21 PIDs und (vielleicht) ein Problem mit dem Powermodul

Benutzeravatar
Kay Hawaii
Drohnenkommandant
Beiträge: 311
Registriert: Fr 18. Nov 2016, 10:55
Wohnort:: Kiel, DE
Kopter & Zubehör: Mavic Pro --- Cheerson CX-20 --- Syma X5SW und ein ruhendes Eigenbauprojekt
Hat sich bedankt: 20 Mal
Danksagung erhalten: 21 Mal

CX-21 PIDs und (vielleicht) ein Problem mit dem Powermodul

Beitragvon Kay Hawaii Sa 7. Okt 2017, 17:22

Hallo alle miteinander,

Zwischenzeitlich habe ich mir ja auch einen CX-21 zusammengezimmert.

Ich nutze den Q380 Frame, die empfohlenen Motoren nebst 1038er Props von Gemfan und ein APM mini 3.1
Als ESC nutze ich einen 4-fach QBrain 25A, den ich auf BLHeli umprogrammiert habe.
konzipiert ist das ganze als ein FPV Modell mit fest installierter Kamera (kein Gimbal o.ä.)

Soweit, so gut. Fliegen tut er auch, allerdings habe ich zwei Probleme

1. PID-Werte
Ich denke, die PID Werte stimmen nicht. Nach einem ersten Flug mit den Standardwerten habe ich die Parameter von Hans aufgespielt.
Damit flog er deutlich besser, kam aber trotzdem immer mal ins "Trudeln".

Dann habe ich andere Werte aufgespielt und zwar

RATE_PIT_D,0.0035
RATE_PIT_I,0.03
RATE_PIT_IMAX,1000
RATE_PIT_P,0.085
RATE_RLL_D,0.0035
RATE_RLL_I,0.03
RATE_RLL_IMAX,1000
RATE_RLL_P,0.085
RATE_YAW_D,0
RATE_YAW_I,0.02
RATE_YAW_IMAX,1000
RATE_YAW_P,0.15
RC_FEEL_RP,10

Damit flog er dann noch ein bisschen besser, wobei ich nicht weiß an welcher Stelle ich tunen soll... Wenn ich das Flugverhalten beschreiben soll, dann wie folgt:

Er hovert sauber in der Luft
Beim Geradeausflug sieht das eigentlich auch ganz sauber aus, aber wenn ich die Sticks loslasse, dann bleibt er nicht einfach stehen wie mein CX-20, sondern kommt so "wellenartig" nach 2-3 Wellenschlägen zum Stehen.
Dasselbe beobachte ich beim Seitwärtsflug.
Beim Sinkflug schaukelt er sich irgendwie auf, es sei denn ich mache das ganz langsam.

Wenn jemand eine Idee hätte, an welchem Wert ich hier drehen müsste, wäre ich dankbar!

2. Powermodul
Ich habe ein Powermodul verbaut und auch richtig verkabelt. Werte kommen an und werden mir über die Telemetrie angezeigt.

Ich habe das Modul auch kalibriert, stelle allerdings fest, dass die Amperewerte sich offenbar ständig verstellen. Das erste mal ist mir das aufgefallen, dass die angezeigte Batteriekapazität dermaßen schnell absank, dass es nur eine Fehlmessung sein konnte. Kein Wunder, beim Abschluss an den PC wurden mir plötzlich Werte von 250 Ampere angezeigt.

Spricht das für ein defektes Powermodul oder hat der APM irgendwie Probleme?


VG
Kay
-------------------
nach Diktat verreist
Benutzeravatar
doelle4
Einsatzleiter ;-)
Beiträge: 7125
Registriert: Sa 25. Jul 2015, 14:32
Wohnort:: A-3900 Kleinreichenbach
Kopter & Zubehör: Cheerson CX20, Mobius Gimbal, FPV, Karbon Beine.
CX-21, Syma X5C ,S-Idee 1151 und andere
Hat sich bedankt: 147 Mal
Danksagung erhalten: 530 Mal
Kontaktdaten:

Re: CX-21 PIDs und (vielleicht) ein Problem mit dem Powermodul

Beitragvon doelle4 Sa 7. Okt 2017, 18:37

Hier was zu Pid Werten: http://www.michael-heck.net/index.php/t ... /pidtuning
bzw hier: cheerson-cx-20-quanum-nova-f8/bitte-um-euere-pid-werte-zum-allgemeinen-nutzen-t678.html

Wie stellst du das Powermodul ein? Ich verwende H4 Autoscheinwerfer Glühlampe die etwa 50 Watt hat am 3S Lipo und ca 4,5 Ampere zieht
Die schliese ich an und messe mit Multimeter die Spannung und dann die Ampere und gebe die Werte im MP zum Abgleich ein.
Spannungswert ist aber weit wichtiger daher diesen messen und ziemlich zeitnah im Mp eingeben bis der richtige Teilerfaktor ermittelt ist und der berechnete Wert ziemlich übereinstimmt.
Gruß Hans
Benutzeravatar
Kay Hawaii
Drohnenkommandant
Beiträge: 311
Registriert: Fr 18. Nov 2016, 10:55
Wohnort:: Kiel, DE
Kopter & Zubehör: Mavic Pro --- Cheerson CX-20 --- Syma X5SW und ein ruhendes Eigenbauprojekt
Hat sich bedankt: 20 Mal
Danksagung erhalten: 21 Mal

Re: CX-21 PIDs und (vielleicht) ein Problem mit dem Powermodul

Beitragvon Kay Hawaii Sa 7. Okt 2017, 19:05

Hi Hans,

ich messe mit laufenden Motoren und umgedrehten Props mit zwischen Akku und Kopter geschaltetem Messgerät. Im Bereich um 20A stelle ich die Werte dann im MP/APM Planner ein.

Beim CX-20 habe ich das einmal eingestellt. Seitdem läuft es.
Beim CX-21 bleiben die Werte irgendwie nicht erhalten und er zeigt mir irgendwelche Fantasiewerte an.

Der Spannungswert funktioniert soweit. Das Problem habe ich nur beim Strom.

VG
Kay
-------------------
nach Diktat verreist
Benutzeravatar
Wolfgang Blumen
Forumskönig
Beiträge: 4122
Registriert: Mo 7. Dez 2015, 01:19
Wohnort:: Saarland
Kopter & Zubehör: CX-20 Cheerson mit Carsten's Ultraleicht-Landegestell u. Gimbal, RunCam1, PM, Telemetrie, OSD, FPV, Spektrum DX18. T-Drones 380er Hexa. Mini Hexe180. EACHINE i6, Falcon180, Hexa QX96. Traxxas Summit. MPX EasyGlider4, FunCub
Hat sich bedankt: 359 Mal
Danksagung erhalten: 412 Mal
Kontaktdaten:

Re: CX-21 PIDs und (vielleicht) ein Problem mit dem Powermodul

Beitragvon Wolfgang Blumen Sa 7. Okt 2017, 22:00

Hallo Kay,

wenn Du noch ein PM hast tausch mal,
oder kontrollier die Lötstellen auf dem PM.

Da gab es mal verkehrte Widerstände:

PM-ALI-5V.jpg


PM-ALI-U-I.jpg
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
liebe Grüße Wolfgang
Benutzeravatar
mastersurferde
Forumskönig
Beiträge: 4168
Registriert: Di 1. Sep 2015, 15:41
Wohnort:: Bayern
Hat sich bedankt: 45 Mal
Danksagung erhalten: 253 Mal

Re: CX-21 PIDs und (vielleicht) ein Problem mit dem Powermodul

Beitragvon mastersurferde Sa 7. Okt 2017, 22:50

Bei den Powermodulen sind viele Nieten im Umlauf - ich hab da auch ein paar davon.
Meistens klappt die Messung nicht, wenn der USB mit dem PC verbunden ist - deswegen stelle ich das immer über die Telemetrie ein.


Nimm mal Pitch_I und Roll_I von 0,03 auf 0,06 hoch - damit sollte es deutlich besser sein.

Gruß
Stefan
Benutzeravatar
Kay Hawaii
Drohnenkommandant
Beiträge: 311
Registriert: Fr 18. Nov 2016, 10:55
Wohnort:: Kiel, DE
Kopter & Zubehör: Mavic Pro --- Cheerson CX-20 --- Syma X5SW und ein ruhendes Eigenbauprojekt
Hat sich bedankt: 20 Mal
Danksagung erhalten: 21 Mal

Re: CX-21 PIDs und (vielleicht) ein Problem mit dem Powermodul

Beitragvon Kay Hawaii So 8. Okt 2017, 22:57

Ich habe mir jetzt mal ein neues Powermodul bestellt...

Danke für die Tips mit den PIDs ... ich werds mal mastersurferde's Tip mit den I-Werten probieren und mich langsam rantasten.

Blöd, dass ich derzeit keine Möglichkeit habe, die Werte auf dem Feld zu ändern und immer ein Stückchen fahren muss, bevor ich fliegen kann :-/

Guten Start in die Woche an alle!

VG
Kay
-------------------
nach Diktat verreist
Benutzeravatar
Kay Hawaii
Drohnenkommandant
Beiträge: 311
Registriert: Fr 18. Nov 2016, 10:55
Wohnort:: Kiel, DE
Kopter & Zubehör: Mavic Pro --- Cheerson CX-20 --- Syma X5SW und ein ruhendes Eigenbauprojekt
Hat sich bedankt: 20 Mal
Danksagung erhalten: 21 Mal

Re: CX-21 PIDs und (vielleicht) ein Problem mit dem Powermodul

Beitragvon Kay Hawaii Mi 18. Okt 2017, 09:17

Wow, nach gerade einmal 8 Tagen sind die Powermodule da.

Bild

Das rote ist dasselbe was ich schon eingebaut habe.

Das andere hat leider keine Beschriftung auf der Platine. Kann da jemand aushelfen?

VG
Kay


Gesendet von iPhone mit Tapatalk
-------------------
nach Diktat verreist
Benutzeravatar
Kay Hawaii
Drohnenkommandant
Beiträge: 311
Registriert: Fr 18. Nov 2016, 10:55
Wohnort:: Kiel, DE
Kopter & Zubehör: Mavic Pro --- Cheerson CX-20 --- Syma X5SW und ein ruhendes Eigenbauprojekt
Hat sich bedankt: 20 Mal
Danksagung erhalten: 21 Mal

CX-21 PIDs und (vielleicht) ein Problem mit dem Powermodul

Beitragvon Kay Hawaii So 22. Okt 2017, 10:50

So,

Ich habe zwischenzeitlich das baugleiche Powermodul eingebaut und hatte danach dieselben Probleme.

Da der Empfänger praktisch direkt neben dem PM installiert ist, habe ich diesen danach in einiger Entfernung angebracht um eventuelle Störsignale auszuschließen. Das hat aber auch nichts gebracht.

Als weitere Fehlerquelle habe ich das Mavlink2Hott Modul neu programmiert (ich fliege mit Graupner). Auch keine Besserung.

Im nächsten Schritt konnte ich das Problem aber nun wohl finden.

Und zwar habe ich nochmal eine Kalibration durchgeführt.

Beim Discomnect habe ich dabei zufällig noch auf die Werte geschaut und gesehen, dass die Ampere per Volt genau beim Klick auf Disconnect von 9.227 auf ca. 164.000 gesprungen sind.

Klar, dass es dann zu solchen Werten kommt.

Habe danach nochmal verbunden und diesen Wert per Hand eingegeben. Diesmal scheint er den auch behalten zu haben.

Mal sehen! Ein erster Test war vielversprechend.

Wenn es das war, dann muss ich nur noch die PIDs in den Griff bekommen. Mastersurferdes Anregung habe ich schon eingetragen.

VG
Kay




Gesendet von iPhone mit Tapatalk
-------------------
nach Diktat verreist
  • Vergleichbare Themen
    Antworten
    Zugriffe
    Letzter Beitrag
  • PIDs / Gains Einstellungen für den ZYX-M
    von DeWe » Di 16. Mai 2017, 22:22 » in APM,Pixhawk,CC3D,Naze
    2
    371
    von DeWe Neuester Beitrag
    Do 25. Mai 2017, 14:32
  • Eachine Falcon 180 PIDs für Einsteiger
    von doelle4 » So 22. Jan 2017, 19:23 » in Cleanflight / INAV
    0
    581
    von doelle4 Neuester Beitrag
    So 22. Jan 2017, 19:23
  • PowerModul Lötstellen im APM 2.5.2 V2 ???
    von matz » Do 10. Dez 2015, 15:59 » in Cheerson CX-20 + Quanum Nova
    21
    1422
    von say no Neuester Beitrag
    Sa 19. Dez 2015, 19:15

Zurück zu „CX-21 & andere Musterkopter Sets“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


FPV Antennen